import re
regex = re.compile(r"(\*+\s+)(\S+)(.+)", flags=re.MULTILINE)
test_str = ("*** A.0044806.1 Project 440064\n"
"*** S.0005049.18.1 Funding FY18\n"
"*** S.0061768.04.01.36.01 SPECIAL PROJECT\n"
"*** S.0072385.001 INSTALL VOICE AND DATE EQUIPMENT")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")