import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\*+\\s+)(\\S+)(.+)";
final String string = "*** A.0044806.1 Project 440064\n"
+ "*** S.0005049.18.1 Funding FY18\n"
+ "*** S.0061768.04.01.36.01 SPECIAL PROJECT\n"
+ "*** S.0072385.001 INSTALL VOICE AND DATE EQUIPMENT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}