package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)https:\/\/(lemdro\.id)\/c\/(.*)`)
var str = `HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs
HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs
Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}