const regex = /https:\/\/(lemdro\.id)\/c\/(.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/(lemdro\\.id)\\\/c\\\/(.*)', 'gmi')
const str = `HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs
HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs
Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}