re = /https:\/\/(lemdro\.id)\/c\/(.*)/mi
str = 'HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs
HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs
Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end