$re = '/https:\/\/(lemdro\.id)\/c\/(.*)/mi';
$str = 'HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs
HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs
Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);