const regex = /\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\\b', 'gmi')
const str = `Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs.`;
const subst = `<span title="" data-term="T: $&" class="grams">$&</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);