#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d*\.?\d*(?<!^\.?)$"
Local $sString = "-7.7" & @CRLF & _
"-18" & @CRLF & _
"0" & @CRLF & _
"." & @CRLF & _
"16." & @CRLF & _
".845" & @CRLF & _
"0.957" & @CRLF & _
"0x45f" & @CRLF & _
"15,87" & @CRLF & _
"#text" & @CRLF & _
"75.95.69" & @CRLF & _
"" & @CRLF & _
"someText"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")