const regex = /^-?\d*\.?\d*(?<!^\.?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?\\d*\\.?\\d*(?<!^\\.?)$', 'gm')
const str = `-7.7
-18
0
.
16.
.845
0.957
0x45f
15,87
#text
75.95.69
someText`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}