$re = '/^-?\d*\.?\d*(?<!^\.?)$/m';
$str = '-7.7
-18
0
.
16.
.845
0.957
0x45f
15,87
#text
75.95.69
someText';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);