re = /^-?\d*\.?\d*(?<!^\.?)$/m
str = '-7.7
-18
0
.
16.
.845
0.957
0x45f
15,87
#text
75.95.69
someText'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end