import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d*\\.?\\d*(?<!^\\.?)$";
final String string = "-7.7\n"
+ "-18\n"
+ "0\n"
+ ".\n"
+ "16.\n"
+ ".845\n"
+ "0.957\n"
+ "0x45f\n"
+ "15,87\n"
+ "#text\n"
+ "75.95.69\n\n"
+ "someText";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}