using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?\d*\.?\d*(?<!^\.?)$";
string input = @"-7.7
-18
0
.
16.
.845
0.957
0x45f
15,87
#text
75.95.69
someText";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}