import re
regex = re.compile(r"^-?\d*\.?\d*(?<!^\.?)$", flags=re.MULTILINE)
test_str = ("-7.7\n"
"-18\n"
"0\n"
".\n"
"16.\n"
".845\n"
"0.957\n"
"0x45f\n"
"15,87\n"
"#text\n"
"75.95.69\n\n"
"someText")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")