# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b0\d*?)0+$/\1/gm;t' <<< "0.24000
4.1100
200
0.100
1.0
00000000
200
230400430000
"