use strict;
my $str = '0.24000
4.1100
200
0.100
1.0
00000000
200
230400430000
';
my $regex = qr/(\b0\d*?)0+$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";