import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b0\\d*?)0+$";
final String string = "0.24000\n"
+ "4.1100\n"
+ "200\n"
+ "0.100\n"
+ "1.0\n"
+ "00000000\n"
+ "200\n"
+ "230400430000\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}