import re
regex = re.compile(r"(\b0\d*?)0+$", flags=re.MULTILINE)
test_str = ("0.24000\n"
"4.1100\n"
"200\n"
"0.100\n"
"1.0\n"
"00000000\n"
"200\n"
"230400430000\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)