using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b0\d*?)0+$";
string substitution = @"\1";
string input = @"0.24000
4.1100
200
0.100
1.0
00000000
200
230400430000
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}