#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\b0\d*?)0+$"
Local $sString = "0.24000" & @CRLF & _
"4.1100" & @CRLF & _
"200" & @CRLF & _
"0.100" & @CRLF & _
"1.0" & @CRLF & _
"00000000" & @CRLF & _
"200" & @CRLF & _
"230400430000" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)