re = /(\b0\d*?)0+$/m
str = '0.24000
4.1100
200
0.100
1.0
00000000
200
230400430000
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result