using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MIB\:\:(.+)\.\d\s\=\sSTRING\:\s(.+)";
string input = @"SPIEE-WIRELESS-MIB::bsnStationMacAddress.0 = STRING: a9:12:fa:13:19:8F
CISCO-LWAPP-UMBH-CALLT-MIB::cldcClientSSID.0 = STRING: Campus-WLAN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}