use strict;
my $str = 'SPIEE-WIRELESS-MIB::bsnStationMacAddress.0 = STRING: a9:12:fa:13:19:8F
CISCO-LWAPP-UMBH-CALLT-MIB::cldcClientSSID.0 = STRING: Campus-WLAN';
my $regex = qr/MIB\:\:(.+)\.\d\s\=\sSTRING\:\s(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}