// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)MIB\:\:(.+)\.\d\s\=\sSTRING\:\s(.+)").unwrap();
let string = "SPIEE-WIRELESS-MIB::bsnStationMacAddress.0 = STRING: a9:12:fa:13:19:8F
CISCO-LWAPP-UMBH-CALLT-MIB::cldcClientSSID.0 = STRING: Campus-WLAN";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}