const regex = /MIB\:\:(.+)\.\d\s\=\sSTRING\:\s(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MIB\\:\\:(.+)\\.\\d\\s\\=\\sSTRING\\:\\s(.+)', 'gm')
const str = `SPIEE-WIRELESS-MIB::bsnStationMacAddress.0 = STRING: a9:12:fa:13:19:8F
CISCO-LWAPP-UMBH-CALLT-MIB::cldcClientSSID.0 = STRING: Campus-WLAN`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}