$re = '/MIB\:\:(.+)\.\d\s\=\sSTRING\:\s(.+)/m';
$str = 'SPIEE-WIRELESS-MIB::bsnStationMacAddress.0 = STRING: a9:12:fa:13:19:8F
CISCO-LWAPP-UMBH-CALLT-MIB::cldcClientSSID.0 = STRING: Campus-WLAN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);