re = /MIB\:\:(.+)\.\d\s\=\sSTRING\:\s(.+)/m
str = 'SPIEE-WIRELESS-MIB::bsnStationMacAddress.0 = STRING: a9:12:fa:13:19:8F
CISCO-LWAPP-UMBH-CALLT-MIB::cldcClientSSID.0 = STRING: Campus-WLAN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end