#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/)?(www\.)?(t\.me|telegram\.dog|telegram\.me)\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\/?"
Local $sString = "t.me/myAlfredo" & @CRLF & _
"t.me/_myAlfredo" & @CRLF & _
"https://telegram.dog/myAlfredo_" & @CRLF & _
"http://telegram.me/my_Alfredo/" & @CRLF & _
"https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")