package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(https?:\/\/)?(www\.)?(t\.me|telegram\.dog|telegram\.me)\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\/?`)
var str = `t.me/myAlfredo
t.me/_myAlfredo
https://telegram.dog/myAlfredo_
http://telegram.me/my_Alfredo/
https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}