import re
regex = re.compile(r"(https?:\/\/)?(www\.)?(t\.me|telegram\.dog|telegram\.me)\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\/?", flags=re.IGNORECASE)
test_str = ("t.me/myAlfredo\n"
"t.me/_myAlfredo\n"
"https://telegram.dog/myAlfredo_\n"
"http://telegram.me/my_Alfredo/\n"
"https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")