import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?(t\\.me|telegram\\.dog|telegram\\.me)\\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\\/?";
final String string = "t.me/myAlfredo\n"
+ "t.me/_myAlfredo\n"
+ "https://telegram.dog/myAlfredo_\n"
+ "http://telegram.me/my_Alfredo/\n"
+ "https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}