$re = '/(https?:\/\/)?(www\.)?(t\.me|telegram\.dog|telegram\.me)\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\/?/i';
$str = 't.me/myAlfredo
t.me/_myAlfredo
https://telegram.dog/myAlfredo_
http://telegram.me/my_Alfredo/
https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);