// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(https?:\/\/)?(www\.)?(t\.me|telegram\.dog|telegram\.me)\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\/?").unwrap();
let string = "t.me/myAlfredo
t.me/_myAlfredo
https://telegram.dog/myAlfredo_
http://telegram.me/my_Alfredo/
https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}