#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\\)(?:\\{2})*\K\\code"
Local $sString = "\\\code" & @CRLF & _
"\\code" & @CRLF & _
"\code"
Local $sSubst = "1234"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)