const regex = /(?<!\\)(?:\\{2})*\K\\code/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)(?:\\\\{2})*\\K\\\\code', 'gm')
const str = `\\\\\\code
\\\\code
\\code`;
const subst = `1234`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);