re = /(?<!\\)(?:\\{2})*\K\\code/m
str = '\\\\\\code
\\\\code
\\code'
subst = '1234'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result