use strict;
my $str = '\\\\\\code
\\\\code
\\code';
my $regex = qr/(?<!\\)(?:\\{2})*\K\\code/mp;
my $subst = '1234';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";