import Foundation
let pattern = #"(?<!\\)(?:\\{2})*\K\\code"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\\\code
\\code
\code
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1234"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)