import re
regex = re.compile(r"(?<!\\)(?:\\{2})*\K\\code", flags=re.MULTILINE)
test_str = ("\\\\\\code\n"
"\\\\code\n"
"\\code")
subst = "1234"
result = regex.sub(subst, test_str)
if result:
print(result)