# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(\[.*?\])[\s\S]*?(^$|\z)/\1/gm;t' <<< "## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature"