package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(\[.*?\])[\s\S]*?(^$|\z)`)
var str = `## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}