#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*(\[.*?\])[\s\S]*?(^$|\z)"
Local $sString = "## [0.3.0] - 2016-12-13" & @CRLF & _
"- FIX This is an example fix" & @CRLF & _
"- FEATURE An example feature" & @CRLF & _
"" & @CRLF & _
"## [0.2.0] - 2015-1-3" & @CRLF & _
"- FIX This is an example fix" & @CRLF & _
"- FEATURE An example feature" & @CRLF & _
"" & @CRLF & _
"## [0.1.0] - 2015-1-3" & @CRLF & _
"- FIX This is an example fix" & @CRLF & _
"- FEATURE An example feature"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)