const regex = /.*(\[.*?\])[\s\S]*?(^$|\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(\\[.*?\\])[\\s\\S]*?(^$|\\z)', 'gm')
const str = `## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);