# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(\[.*?\])[\s\S]*?(^$|\z)"
test_str = ("## [0.3.0] - 2016-12-13\n"
"- FIX This is an example fix\n"
"- FEATURE An example feature\n\n"
"## [0.2.0] - 2015-1-3\n"
"- FIX This is an example fix\n"
"- FEATURE An example feature\n\n"
"## [0.1.0] - 2015-1-3\n"
"- FIX This is an example fix\n"
"- FEATURE An example feature")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.