using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\[.*?\])[\s\S]*?(^$|\z)";
string substitution = @"\1";
string input = @"## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}