#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^,]*,){2}\K[^,\n]+(?=(?:,[^,\n]*){3},4[0-9][0-9],)"
Local $sString = "field1,field2,Name 1,field4,field5,field6,101, field8" & @CRLF & _
"field1,field2,Name 2,field4,field5,field6,499, field8" & @CRLF & _
"field1,field2,Name 3,field4,field5,field6,500, field8" & @CRLF & _
"field1,field2,Name 4,field4,field5,field6,4214.00, field8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")