import Foundation
let pattern = #"^(?:[^,]*,){2}\K[^,\n]+(?=(?:,[^,\n]*){3},4[0-9][0-9],)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
field1,field2,Name 1,field4,field5,field6,101, field8
field1,field2,Name 2,field4,field5,field6,499, field8
field1,field2,Name 3,field4,field5,field6,500, field8
field1,field2,Name 4,field4,field5,field6,4214.00, field8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)