$re = '/^(?:[^,]*,){2}\K[^,\n]+(?=(?:,[^,\n]*){3},4[0-9][0-9],)/m';
$str = 'field1,field2,Name 1,field4,field5,field6,101, field8
field1,field2,Name 2,field4,field5,field6,499, field8
field1,field2,Name 3,field4,field5,field6,500, field8
field1,field2,Name 4,field4,field5,field6,4214.00, field8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);