const regex = /^(?:[^,]*,){2}\K[^,\n]+(?=(?:,[^,\n]*){3},4[0-9][0-9],)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^,]*,){2}\\K[^,\\n]+(?=(?:,[^,\\n]*){3},4[0-9][0-9],)', 'gm')
const str = `field1,field2,Name 1,field4,field5,field6,101, field8
field1,field2,Name 2,field4,field5,field6,499, field8
field1,field2,Name 3,field4,field5,field6,500, field8
field1,field2,Name 4,field4,field5,field6,4214.00, field8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}