import re
regex = re.compile(r"^(?:[^,]*,){2}\K[^,\n]+(?=(?:,[^,\n]*){3},4[0-9][0-9],)", flags=re.MULTILINE)
test_str = ("field1,field2,Name 1,field4,field5,field6,101, field8\n"
"field1,field2,Name 2,field4,field5,field6,499, field8\n"
"field1,field2,Name 3,field4,field5,field6,500, field8\n"
"field1,field2,Name 4,field4,field5,field6,4214.00, field8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")